Back to overview
Degraded

Payment Processing is currently unavailable

Feb 18, 2026 at 11:00pm UTC
Affected services
Cm3 WebPortal
Payment Gateway

Resolved
Feb 19, 2026 at 2:15am UTC

Services have returned to normal. Thank you for your patience.

Created
Feb 18, 2026 at 11:00pm UTC

Currently payments are impacted by an outage with our upstream payment provider; Braintree.

For up to date information if required, please check their status page: https://www.paypal-status.com/product/production

We appreciate your patience and are working to restore services as soon as we can.